Optika

1 / 10
2 / 10
3 / 10
4 / 10
5 / 10
6 / 10
7 / 10
8 / 10
9 / 10
10 / 10
Region GLOBAL
Platform STEAM
INSTANT DELIVRY

PRICE
200
$4.99 100% OFF
Live Stock Report You receive your product instantly.
Additional information
Release date
Aug 26, 2016
Languages
German, Spanish, French, English, Italian

Instructions to activate Optika key free

(1) Launch Steam and log into your Steam account. (2) Click the Games Menu. (3) Choose Activate a Product on Steam. (4) Follow the onscreen instructions to activate Optika key. After successful code verification go to the "MY GAMES" tab and start downloading.
Recommended products
Description

Description of Optika cd key free

Optika steam cd key for free on SteamGateways. FREE STEAM KEYS. CD Keys Gift. Instant download. FREE STEAM GAMES. Instant delivery 24/7. FREE Codes & Giveaways. Optika free steam key

Optika steam key free

Optika is a puzzle game where you control light with 14 different optic devices to complete levels. Be ingenious and lead the right color to the Receivers with the help of Professor Opticus and Sofia! Decompose and move the light thanks to lenses, mirrors and prisms. Take your time and ultimately guide the photons to their goals! - 160 levels - Discover 14 different optical devices - Play with light and colors - Use lenses, mirrors and prisms - Soothing soundtrack Discover the world of light physics: play with lasers, prisms, mirrors, magnets and dozens of other optical devices. Explore the world of Optika with Prof. Opticus and his assistant, Sofia! Research and complete more than one hundred challenging puzzles! All of the puzzles you are about to experience are inspired by real world physics.
Source: steampowered.com

System requirements
Windows Requirements
最低配備:
  • 作業系統: Windows 7, Windows 8.1, Windows 10, Windows XP or Windows Server 2008
  • 處理器: 2.33GHz or faster x86-compatible processor or Intel Atom 1.6GHz or faster processor for notebook class devices
  • 記憶體: 512 MB 記憶體
  • 顯示卡: Any GPU
  • 儲存空間: 100 MB 可用空間
Mac Requirements
Not available.
Linux Requirements
Not available.