Neckbeards: Silly Squadron

1 / 6
2 / 6
3 / 6
4 / 6
5 / 6
6 / 6
Region GLOBAL
Platform STEAM
INSTANT DELIVRY

PRICE
200
$4.99 100% OFF
Live Stock Report You receive your product instantly.
Additional information
Release date
Jan 9, 2018
Languages
German, Spanish, French, English, Italian

Instructions to activate Neckbeards: Silly Squadron steam key free

(1) Launch Steam and log into your Steam account. (2) Click the Games Menu. (3) Choose Activate a Product on Steam. (4) Follow the onscreen instructions to activate Neckbeards: Silly Squadron key. After successful code verification go to the "MY GAMES" tab and start downloading.
Recommended products
Description

Description of Neckbeards: Silly Squadron free steam key

Free Neckbeards: Silly Squadron steam key gift on SteamGateways. Free steam games. Free steam keys. CD Keys Gift. Instant download. Instant delivery 24/7. Free Codes & Giveaways. Neckbeards: Silly Squadron cd key free

Neckbeards: Silly Squadron key free

The toughest arcade challenge yet. Insert coin if you dare.

Silly Squadron is a retro-futuristic take on Space Invaders, the arcade classic from 1978. It has all the Soiree ingredients youre craving for: fast action, addictive gameplay, strange boss fights (including a mighty middle-aged man) and a seriously sumptuous soundtrack.

  • Commandeer a variety of cannons, each offering unique qualities and/or weapons systems
  • Team up with a buddy in local co-op (or tag team with your CPU if you are friendless)
  • Watch out for kamikaze beta males, master cucks, and a dozen more special enemies
  • Befriend invaders to have them join you as meat-shields in the next level
  • Clear seven worlds of enemies to enter Deluge, the hardest single non-stop level in any arcade game, ever! (even the pause-mode is disabled in Deluge)

Source: steampowered.com

System requirements
Windows Requirements
  • OS: Windows Vista/7/8/10
  • Processor: Dual Core
  • Memory: 512 MB RAM
  • DirectX: Version 9.0c
  • Storage: 156 MB available space
Mac Requirements
Not available.
Linux Requirements
Not available.