Cargo Breach

1 / 12
2 / 12
3 / 12
4 / 12
5 / 12
6 / 12
7 / 12
8 / 12
9 / 12
10 / 12
11 / 12
12 / 12
Region GLOBAL
Platform STEAM
INSTANT DELIVRY

PRICE
200
$0.99 100% OFF
Live Stock Report You receive your product instantly.
Additional information
Release date
Oct 13, 2017
Languages
German, Spanish, French, English, Italian

Instructions to activate Cargo Breach cd key free

(1) Launch Steam and log into your Steam account. (2) Click the Games Menu. (3) Choose Activate a Product on Steam. (4) Follow the onscreen instructions to activate Cargo Breach key. After successful code verification go to the "MY GAMES" tab and start downloading.
Recommended products
Description

Description of Cargo Breach steam key free

Cargo Breach steam key for free. Free Codes & Giveaways. Free steam keys. Instant delivery 24/7. CD Keys Gift. Instant download. Free steam games. Cargo Breach key free

Cargo Breach free steam key


Cargo is Breached!

Cargo Breach is an Intense VR Arcade Shooter with Unique Weapon Mechanics. You hunt down escaped creatures in dark atmospheric spaceship corridors. All presented in stunning AAA graphics.

Features:

- Gesture based gun mechanics allow you to switch guns by aligning your controllers differently. For instance hold one behind the other to form the "Shocker".

- Various weapon types that each have a different impact on the threats.

- Randomized Level creation. Each run will be different, Blasting numerous waves of creatures along the way.

- Amazing spatialized audio allows you to locate your enemies in the dark.

- Stunning state of the art, High-end Triple A+ graphics.
Source: steampowered.com

System requirements
Windows Requirements
  • Requires a 64-bit processor and operating system
  • OS: Windows 7 - 64 bit
  • Processor: Intel i5-4590 equivalent or greater
  • Memory: 8 GB RAM
  • Graphics: NVIDIA GTX 970 / AMD equivalent or greater
  • DirectX: Version 11
  • Storage: 1500 MB available space
  • Sound Card: Integrated
  • Additional Notes: VR Headset required, 2x USB 3.0 ports
Mac Requirements
Not available.
Linux Requirements
Not available.